root/lm-sensors/branches/lm-sensors-3.0.0/lib/sysfs.c

Revision Log Mode:


Legend:

Added
Modified
Copied or renamed
Diff Rev Chgset Date Author Log Message
(edit) @5593 [5593] 6 years jwrdegoede Add ACPI bus
(edit) @5379 [5379] 6 years khali Add support for current sensors.
(edit) @5378 [5378] 6 years khali Add support for instantaneous power sensors.
(edit) @5183 [5183] 6 years djwong Subject: [PATCH 1/3 v3] libsensors: Support energy and power meters Add …
(edit) @5176 [5176] 6 years khali Add support for virtual hwmon devices. This closes Red Hat bug #437637 and …
(edit) @5174 [5174] 6 years djwong Subject: [PATCH 1/4] libsensors: Detect OpenFirmware? hwmon devices On a …
(edit) @5163 [5163] 7 years khali Patch from Aurelien Jarno: I have just noticed that the FSF address is …
(edit) @5145 [5145] 7 years jwrdegoede The platform case acts as a fallback solution so it must be last in the …
(edit) @5134 [5134] 7 years khali Use func instead of FUNCTION. The former is standard, the latter …
(edit) @5093 [5093] 7 years khali Add support for drivers that place the hwmon attributes in the hwmon class …
(edit) @5092 [5092] 7 years khali Get the device type from the subsystem symlink, rather than guessing it …
(edit) @5075 [5075] 7 years mmh libsensors: minor cleanup
(edit) @5067 [5067] 7 years khali libsensors: No longer depend on libsysfs. Instead, access sysfs directly, …
(edit) @4899 [4899] 7 years khali libsensors: Report I/O errors as such.
(edit) @4896 [4896] 7 years khali libsensors: Differentiate between different read error types.
(edit) @4895 [4895] 7 years khali libsensors: Notify the caller when writing a value fails.
(edit) @4879 [4879] 7 years khali Drop SENSORS_ERR_NO_DEVS: we return success, not error, when no device is …
(edit) @4878 [4878] 7 years khali Add support for platform devices with no ID.
(edit) @4858 [4858] 7 years khali Renumber feature and subfeature types to leave more room if we later need …
(edit) @4855 [4855] 7 years khali Don't arbitrarily write errors to stderr. In production mode, simply …
(edit) @4854 [4854] 7 years khali Delete unused SENSORS_ERR_ACCESS. Rename SENSORS_ERR_PROC to the more …
(edit) @4850 [4850] 7 years khali Better prototype for get_type_scaling().
(edit) @4841 [4841] 7 years khali Pass a subfeature structure to sensors_read_sysfs_attr() and …
(edit) @4838 [4838] 7 years khali Introduce a separate type for main features. Make subfeatures map to the …
(edit) @4837 [4837] 7 years khali Rename subfeature types from *_FEATURE_* to *_SUBFEATURE_*, to better …
(edit) @4836 [4836] 7 years khali Update the comments and symbols in the whole library code to refer to …
(edit) @4834 [4834] 7 years khali Define a separate structure to represent main features. This allows for …
(edit) @4832 [4832] 7 years khali Rename struct sensors_feature_data to sensors_subfeature. This is a first …
(edit) @4830 [4830] 7 years khali sensors_feature_data and sensors_chip_feature are now the exact same …
(edit) @4829 [4829] 7 years khali Fix compilation breakage with non-C99 compilers.
(edit) @4826 [4826] 7 years khali Add support for beep features.
(edit) @4776 [4776] 7 years khali Move sensors_feature_get_type() from access.c to sysfs.c, it's only called …
(edit) @4769 [4769] 7 years khali Add support for temperature offset files, which are part of the standard …
(edit) @4766 [4766] 7 years khali Add support for the standard beep_enable attribute (#2248).
(edit) @4765 [4765] 7 years khali Increase MAX_SENSORS_PER_TYPE from 16 to 20: the ADM1026 can have up to 17 …
(edit) @4764 [4764] 7 years khali Another minor optimization to sensors_read_dynamic_chip(): * We don't need …
(edit) @4763 [4763] 7 years khali Minor optimizations in sensors_read_dynamic_chip(): * We don't need to …
(edit) @4762 [4762] 7 years khali Now that we can deduce the scaling factor required for each feature from …
(edit) @4761 [4761] 7 years khali Optimize the memory consumption in sensors_read_dynamic_chip(). The idea …
(edit) @4760 [4760] 7 years khali Store the feature list length separately instead of null-terminating the …
(edit) @4759 [4759] 7 years khali Renumber the features linearly, so that feature number N is at position N …
(edit) @4758 [4758] 7 years khali The compute mapping value is either SENSORS_NO_MAPPING or the same feature …
(edit) @4757 [4757] 7 years khali Rename sensors_feature_data.mode to flags, as we plan to use it to store …
(edit) @4744 [4744] 7 years khali Start numbering the features at 0, not 1. There's nothing wrong with …
(edit) @4743 [4743] 7 years khali Use the feature type rather than the feature name to figure out whether we …
(edit) @4742 [4742] 7 years khali Drop useless return.
(edit) @4736 [4736] 7 years khali Mass reindent, coding style and whitespace cleanups.
(edit) @4732 [4732] 7 years khali Make SENSORS_FEATURE_MAX_SUB_FEATURES private (and rename it to …
(edit) @4731 [4731] 7 years khali Allocate the large sparse feature table in sensors_read_dynamic_chip() …
(edit) @4689 [4689] 7 years khali Add support for hardware monitoring chips on SPI buses. SPI bus …
(edit) @4687 [4687] 7 years khali Support more bus types (part 2 of 2). Originally libsensors was very …
(edit) @4686 [4686] 7 years khali Support more bus types (part 1 of 2). Originally libsensors was very …
(edit) @4674 [4674] 7 years khali Don't handle the isa bus in sensors_parse_i2cbus_name(). We really don't …
(edit) @4673 [4673] 7 years khali Rename sensors_chip_name.busname to path, as this is what we are using it …
(edit) @4672 [4672] 7 years khali Drop support for "dummy" bus type. The kernel no longer supports such fake …
(edit) @4667 [4667] 7 years khali Pass the structures by reference inside libsensors. Again a small …
(edit) @4638 [4638] 7 years khali No need to explicitly discard subclients. With the hwmon class, they won't …
(edit) @4637 [4637] 7 years khali Discard devices with zero feature.
(edit) @4636 [4636] 7 years khali Fix a memory leak in sensors_read_one_sysfs_chip() when an error occurs.
(edit) @4630 [4630] 7 years khali Now that sensors_feature_get_type() is an internal function, we can adjust …
(edit) @4629 [4629] 7 years khali The way we use sensors_feature_get_type() is rather suboptimal. It is …
(edit) @4616 [4616] 7 years khali No special treatment is needed for the name attribute.
(edit) @4554 [4554] 7 years khali Add support for multiple VID values. Untested as I don't have a chip with …
(edit) @4553 [4553] 7 years khali Move sensors_proc_read and sensors_proc_write to sysfs.c, and rename them …
(edit) @4545 [4545] 7 years khali Add some more warning flags, and fix these warnings.
(edit) @4543 [4543] 7 years khali Drop VRM reporting and selection support from libsensors. Since kernel …
(edit) @4521 [4521] 7 years khali Simplify the code setting the feature mode.
(edit) @4510 [4510] 7 years khali With the new dynamic chip features enumeration code, the …
(edit) @4509 [4509] 7 years khali Feature names are now dynamically allocated -> no const.
(edit) @4508 [4508] 7 years khali Use complete chip names (prefix + bus + address) as the keys of …
(edit) @4474 [4474] 7 years khali struct sensors_proc_chips_entry now has a single member, so we may as well …
(edit) @4464 [4464] 7 years khali Return with an explicit error code/message if sysfs isn't mounted.
(edit) @4462 [4462] 7 years khali libsensors: Kill procfs support, part 1.
(edit) @4420 [4420] 7 years khali Fill the magnitude field of dynamically generated device entries.
(edit) @4403 [4403] 7 years khali libsensors: Drop support for non-sensor drivers: ddcmon and eeprom. These …
(edit) @4368 [4368] 7 years jwrdegoede -rewrite dyn chip code, it now uses sensors_feature_get_type() to …
(edit) @4367 [4367] 7 years jwrdegoede -comment abituguru entry in lib/chips.c and prog/sensors/main.c, as the …
(edit) @4359 [4359] 7 years jwrdegoede dynamicly generate a sensors_chip_features_list entry for unknown chips …
(edit) @4357 [4357] 8 years mmh Merge from trunk (4303:4355) out to 3.0.0 branch.
(copy) @4303 [4303] 8 years mmh Create a branch for 3.0.0.
copied from lm-sensors/trunk/lib/sysfs.c:
(edit) @4267 [4267] 8 years khali libsensors: Get the i2c adapter names from the class device's "name" …
Note: See TracRevisionLog for help on using the revision log.