Ticket #1003 (closed task)

Opened 8 years ago

p4b_smbus.o unresolved symbols (Examined/Solved - lm_sensors 2.6.3 Linux 2.4.18)

Reported by: contact Owned by: somebody
Priority: minor Milestone:
Component: kernel Version:
Keywords: Cc:

Description

I am getting unresolved symbols when I load the p4b_smbus module on my P4B-SWA

motherboard. I tried the items in the FAQ 3.9 and in nm --extern p4b_smbus.o,

the three unresolved symbols (pci_insert_device, pci_setup_device, and

pci_remoeve_device) return no numbers in the symbol list. In /proc/ksyms they

do.

I am using a stock kernel 2.4.18, with i2c as modules (using the latest version

available from your site) and I do have hotplug enabled. Any suggestions on

how to get this to work?

Thanks

Chris

--- Makefile.p4b doesn't have a 'magic' detection of CONFIG_MODVERSIONS,

that may be it.

If you look at the top-level makefile, where it checks for CONFIG_MODVERSIONS

and then adds some things to the compile line

when that exists, see if you can modify the Makefile.p4b to add that.

I think that should do it.

If you get it working please send us a patch for Makefile.p4b.

Follow up by emailing us, ref. your ticket number.

MDS 7/17/02


Fixed in Makefile.p4b and the driver,

in CVS / 2.6.5.

MDS 8/10/02

Note: See TracTickets for help on using tickets.