Ticket #1628 (closed task)

Opened 9 years ago

2.7.0 proc/bus/i2c missing and 2.8.4 will not make (Examined/Solved - lm_sensors 2.7.0 - 2.8.4Linux 2.6.2)

Reported by: contact Owned by: somebody
Priority: minor Milestone:
Component: kernel Version:
Keywords: Cc:

Description

Had lm_sensors running fine as 2.7.0 and kernel 2.4, upgraded to 2.6.2 and

sensors(as root) gives

Can't access /proc file

/proc/sys/dev/sensors/chips or /proc/bus/i2c unreadable;

Make sure you have done 'modprobe i2c-proc'!

sensors-detect(as root) fails with

Couldn't open /proc/bus/i2c?!? at /usr/local/sbin/sensors-detect line 3184,

<STDIN> line 4.

What ever route I take with modules

mount shows /oroc and sysfs

proc on /proc type proc (rw)

devpts on /dev/pts type devpts (rw,gid=5,mode=620)

none on /proc/bus/usb type usbdevfs (rw)

none on /sys type sysfs (rw,default)

============================================================

lsmod shows

Module Size Used by

i2c_via 3584 0

i2c_algo_bit 8840 1 i2c_via

i2c_dev 8704 0

i2c_viapro 6220 0

i2c_core 18737 1

sr_mod 13408 0

uhci_hcd 28872 0

ide_scsi 11908 0

ide_cd 35968 0

cdrom 34396 2 sr_mod,ide_cd

natsemi 21152 0

nvidia 2070888 12

usb_storage 38848 0

usbcore 102548 4 uhci_hcd,usb_storage

videodev 7936 0

rtc 10568 0

Did also try rmmod'ing all i2c b4 running sensor-detect

============================================================

lspci shows

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)

00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)

00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)

00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)

00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)

00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)

00:0b.0 Ethernet controller: National Semiconductor Corporation DP83815

(MacPhyter?) Ethernet Controller

00:0c.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)

00:0e.0 Communication controller: Ambient Technologies Inc: Unknown device 4000

(rev 02)

01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0312 (rev a1)

============================================================

here is the i2c section from the config file

#

# I2C support

#

CONFIG_I2C=y

CONFIG_I2C_CHARDEV=m

#

# I2C Algorithms

#

CONFIG_I2C_ALGOBIT=m

CONFIG_I2C_ALGOPCF=m

#

# I2C Hardware Bus support

#

# CONFIG_I2C_ALI1535 is not set

# CONFIG_I2C_ALI15X3 is not set

# CONFIG_I2C_AMD756 is not set

# CONFIG_I2C_AMD8111 is not set

# CONFIG_I2C_ELV is not set

# CONFIG_I2C_I801 is not set

# CONFIG_I2C_I810 is not set

CONFIG_I2C_ISA=m

# CONFIG_I2C_NFORCE2 is not set

# CONFIG_I2C_PHILIPSPAR is not set

# CONFIG_I2C_PARPORT is not set

# CONFIG_I2C_PARPORT_LIGHT is not set

# CONFIG_I2C_PIIX4 is not set

# CONFIG_I2C_PROSAVAGE is not set

# CONFIG_I2C_SAVAGE4 is not set

# CONFIG_SCx200_ACB is not set

# CONFIG_I2C_SIS5595 is not set

# CONFIG_I2C_SIS630 is not set

# CONFIG_I2C_SIS96X is not set

# CONFIG_I2C_VELLEMAN is not set

# CONFIG_I2C_VIA is not set

CONFIG_I2C_VIAPRO=m

# CONFIG_I2C_VOODOO3 is not set

#

# I2C Hardware Sensors Chip support

#

CONFIG_I2C_SENSOR=m

# CONFIG_SENSORS_ADM1021 is not set

# CONFIG_SENSORS_ASB100 is not set

# CONFIG_SENSORS_EEPROM is not set

# CONFIG_SENSORS_IT87 is not set

# CONFIG_SENSORS_LM75 is not set

# CONFIG_SENSORS_LM78 is not set

# CONFIG_SENSORS_LM83 is not set

# CONFIG_SENSORS_LM85 is not set

# CONFIG_SENSORS_LM90 is not set

CONFIG_SENSORS_VIA686A=m

# CONFIG_SENSORS_W83781D is not set

# CONFIG_SENSORS_W83L785TS is not set

CONFIG_I2C_DEBUG_CORE=y

CONFIG_I2C_DEBUG_BUS=y

CONFIG_I2C_DEBUG_CHIP=y

============================================================

and best of all trying to compile 2.8.4 with make user ends with

make: *** No rule to make target 'user'. Stop.

After making loads of stuff but then follow that with make user_install and get

gcc -M -MG -I/lib/modules/2.6.2/build/include -nostdinc -I

/usr/lib/gcc-lib/i386-linux/2.95.4/include -Wall -O2 -DLM_SENSORS -DKERNEL

-DMODULE -fomit-frame-pointer -DEXPORT_SYMTAB kernel/i2c-dev.c | \

sed -e 's@\(.*\)\.o:@kernel/i2c-dev.d kernel/i2c-dev.o: Makefile dirname

kernel/i2c-dev.d'/Module.mk' @' > kernel/i2c-dev.d

make: *** No rule to make target 'user_install'. Stop.

make all gives

kernel/i2c-dev.c: In function 'i2cdev_open':

kernel/i2c-dev.c:424: called object is not a function

kernel/i2c-dev.c:452: warning: implicit declaration of function

'MOD_INC_USE_COUNT'

kernel/i2c-dev.c: In function 'i2cdev_release':

kernel/i2c-dev.c:470: warning: implicit declaration of function

'MOD_DEC_USE_COUNT'

kernel/i2c-dev.c: At top level:

kernel/i2c-dev.c:574: warning: type defaults to 'int' in declaration of

'EXPORT_NO_SYMBOLS'

kernel/i2c-dev.c:574: warning: data definition has no type or storage class

make: *** [kernel/i2c-dev.o] Error 1

after making stuff

make on its own results in exactly the same error.

make install ends it the same error

so, should kernel 2.6.2 work with sensors 2.7.0 ?

and if not how can i install a later version ?

thanks for any help/advise you can give me --- see our 2.6 kernel info page for compatibility between sensors

releases and 2.6 kernel releases.

Sensors 2.7.0 won't work with 2.6 kernels.

If you do want 2.7.0 to work with kernel 2.4 you have to modprobe i2c-proc

like the error message says.

You shouldn't need to build i2c for 2.6 kernels, just build sensors.

Note: See TracTickets for help on using tickets.