Ticket #2152 (closed defect: wontfix)

Opened 7 years ago

Last modified 5 years ago

k8temp reports wrong values

Reported by: simon@… Owned by: ruik
Priority: minor Milestone:
Component: hardware Version: kernel
Keywords: Cc:

Description

hi,

i get this of sensors on my asus m2n-e:

k8temp-pci-00c3
Adapter: PCI adapter
temp1:       +18 C
temp3:       +17 C

it8716-isa-0290
Adapter: ISA adapter
VCore:     +0.96 V  (min =  +0.00 V, max =  +4.08 V)
VDDR:      +3.20 V  (min =  +0.00 V, max =  +4.08 V)
+3.3V:     +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
+5V:       +4.89 V  (min =  +0.00 V, max =  +6.85 V)
+12V:     +11.71 V  (min =  +0.00 V, max = +16.32 V)
in5:       +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
in6:       +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
5VSB:      +4.81 V  (min =  +0.00 V, max =  +6.85 V)
VBat:      +2.93 V
CPU Fan:  2272 RPM  (min =    0 RPM)
fan2:        0 RPM  (min =    0 RPM)
CPU Temp:    +78 C  (low  =    -1 C, high =  +127 C)   sensor = thermistor
M/B Temp:    +33 C  (low  =    -1 C, high =  +127 C)   sensor = thermistor
vid:      +1.100 V

so the 18 / 17 C are way too cool imo...

some more info:

sensors version 2.10.1 with libsensors version 2.10.1
Linux d-partment 2.6.19-gentoo-r1 #4 SMP PREEMPT Wed Dec 6 17:13:36 CET 2006
x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ AuthenticAMD GNU/Linux

any hints?

Change History

  Changed 7 years ago by ticket

some more info: runnign on a am2 socket

cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 75
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
stepping        : 2
cpu MHz         : 1000.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 2010.94
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 75
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
stepping        : 2
cpu MHz         : 1000.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 2010.94
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

  Changed 7 years ago by khali

  • priority changed from major to minor
  • version set to kernel
  • reporter changed from ticket to simon@…

  Changed 7 years ago by ticket

{{{lspci -xxx -s 00:18.3 00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control 00: 22 10 03 11 00 00 10 00 00 00 00 06 00 00 80 00 10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 30: 00 00 00 00 f0 00 00 00 00 00 00 00 00 00 00 00 40: ff 3b 04 00 40 00 10 0a 00 00 00 00 00 00 00 00 50: e8 fa c1 f4 ff 00 00 00 00 00 00 00 80 ef f6 7f 60: ff 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 70: 11 01 02 51 22 30 00 50 00 1b 00 08 2a 22 00 00 80: 00 00 07 23 13 21 13 21 00 00 00 00 00 00 00 00 90: 00 00 00 00 40 1b 00 00 80 07 f0 df 00 00 00 00 a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 d0: 00 00 00 00 01 a7 0d 00 00 00 80 00 25 25 25 00 e0: 00 00 00 00 24 1b 45 00 19 17 00 00 00 00 00 00 f0: 0f 00 10 00 00 00 00 00 00 00 00 00 b2 0f 04 00 }}}

  Changed 7 years ago by ruik

  • owner changed from somebody to ruik
  • status changed from new to assigned
lspci -xxx -s 00:18.3 00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
00: 22 10 03 11 00 00 10 00 00 00 00 06 00 00 80 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
30: 00 00 00 00 f0 00 00 00 00 00 00 00 00 00 00 00
40: ff 3b 04 00 40 00 10 0a 00 00 00 00 00 00 00 00
50: e8 fa c1 f4 ff 00 00 00 00 00 00 00 80 ef f6 7f
60: ff 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 11 01 02 51 22 30 00 50 00 1b 00 08 2a 22 00 00
80: 00 00 07 23 13 21 13 21 00 00 00 00 00 00 00 00
90: 00 00 00 00 40 1b 00 00 80 07 f0 df 00 00 00 00
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 01 a7 0d 00 00 00 80 00 25 25 25 00
e0: 00 00 00 00 24 1b 45 00 19 17 00 00 00 00 00 00
f0: 0f 00 10 00 00 00 00 00 00 00 00 00 b2 0f 04 00

  Changed 7 years ago by ruik

Hello,

At first check, the raw temps are same as the drivers, so maybe there is some other offset :/ Lets fix the IT8716 temperature first.

Please can you add to your config file:

set sensor1 3

Into the correct section (it8716 one) Then run:

sensors -s
sensors

You should see that CPU temp changed to diode input, also the temp should change. Please post the output here.

Thanks,

Rudolf

  Changed 7 years ago by ticket

the new temperature is 27C ... have to check in bios whats reported there

sensors
k8temp-pci-00c3
Adapter: PCI adapter
temp1:       +18 C
temp3:       +17 C

it8716-isa-0290
Adapter: ISA adapter
VCore:     +0.96 V  (min =  +0.00 V, max =  +4.08 V)
VDDR:      +3.20 V  (min =  +0.00 V, max =  +4.08 V)
+3.3V:     +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
+5V:       +4.89 V  (min =  +0.00 V, max =  +6.85 V)
+12V:     +11.65 V  (min =  +0.00 V, max = +16.32 V)
in5:       +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
in6:       +0.00 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
5VSB:      +4.81 V  (min =  +0.00 V, max =  +6.85 V)
VBat:      +2.93 V
CPU Fan:  2288 RPM  (min =    0 RPM)
fan2:        0 RPM  (min =    0 RPM)
CPU Temp:    +26 C  (low  =    -1 C, high =  +127 C)   sensor = diode
M/B Temp:    +33 C  (low  =    -1 C, high =  +127 C)   sensor = thermistor
vid:      +1.100 V


in reply to: ↑ description   Changed 7 years ago by ticket

Replying to simon@aktionspotenzial.de:

hi, i get this of sensors on my asus m2n-e: {{{ k8temp-pci-00c3 Adapter: PCI adapter temp1: +18 C temp3: +17 C it8716-isa-0290 Adapter: ISA adapter VCore: +0.96 V (min = +0.00 V, max = +4.08 V) VDDR: +3.20 V (min = +0.00 V, max = +4.08 V) +3.3V: +0.00 V (min = +0.00 V, max = +4.08 V) ALARM +5V: +4.89 V (min = +0.00 V, max = +6.85 V) +12V: +11.71 V (min = +0.00 V, max = +16.32 V) in5: +0.00 V (min = +0.00 V, max = +4.08 V) ALARM in6: +0.00 V (min = +0.00 V, max = +4.08 V) ALARM 5VSB: +4.81 V (min = +0.00 V, max = +6.85 V) VBat: +2.93 V CPU Fan: 2272 RPM (min = 0 RPM) fan2: 0 RPM (min = 0 RPM) CPU Temp: +78 C (low = -1 C, high = +127 C) sensor = thermistor M/B Temp: +33 C (low = -1 C, high = +127 C) sensor = thermistor vid: +1.100 V }}} so the 18 / 17 C are way too cool imo... some more info: {{{ sensors version 2.10.1 with libsensors version 2.10.1 Linux d-partment 2.6.19-gentoo-r1 #4 SMP PREEMPT Wed Dec 6 17:13:36 CET 2006 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ AuthenticAMD GNU/Linux }}} any hints?

I also suffer from the same problem.

I'm running an AMD Athlon 64 x2 4000+ on an Asus M2NPV-MX and sensors returns unrealistic temperatures. Check bellow:

<cmd> rui@desktop:~$ sensors k8temp-pci-00c3 Adapter: PCI adapter Core0 Temp:

+12°C

Core0 Temp:

-1°C

Core1 Temp:

+7°C

Core1 Temp:

+1°C

rui@desktop:~$ sensors -v sensors version 2.10.1 with libsensors version 2.10.1 </cmd>

Those are some strange numbers.

What can I do to correct those numbers?

  Changed 5 years ago by ruik

  • status changed from assigned to closed
  • resolution set to wontfix

Hmm this is known bug of K8 CPU. Nofix.

Note: See TracTickets for help on using tickets.