Ticket #2213 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Asus M2NPV-VM / IT87 : What worked in LM_Sensors 2.9.1 doesn't in 2.10.2 anymore

Reported by: michel@… Owned by: khali
Priority: major Milestone:
Component: hardware Version: 2.10.2
Keywords: Cc:

Description (last modified by khali) (diff)

Hi there,

I have an Asus M2NPV-VM mobo on which I used a Mandriva 2007.0 with a 2.6.12 kernel and lm_sensors 2.9.1. With this, I had an "IT87" chip recognized on the mobo, and it was working quite good except for a little weirdness (voltages reported were crazy if I set "fan2" to anything else than "ignore fan2", and voltages were plain good with fan2 ignored... Weird enough).

I upgraded to Mandriva 2007.1, kernel 2.6.17, lm_sensors 2.10.2 (with basically the same sensors.conf file and modules loaded, except that now "it87" causes a "hwmon_vid" module to be loaded, wich I don't think existed before...?).

But now :

# lsmod | egrep "i2c|it87"
i2c_dev                 8036  0
i2c_nforce2             6592  0
it87                   18852  0
hwmon_vid               3296  1 it87
i2c_isa                 4192  1 it87
i2c_core               17344  6 i2c_dev,i2c_nforce2,nvidia,it87,eeprom,i2c_isa

# sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.

# sensors-detect
[...blah-blah...]
Driver `it87' (should be inserted):
  Detects correctly:
  * ISA bus, address 0x290 (Busdriver `i2c-isa')
    Chip `ITE IT8716F Super IO Sensors' (confidence: 9)
[...blah-blah...]

So sensors-detect still sees the IT87, but the true module, once loaded, doesn't find the chip and complains "No sensors !" where it was working good with previous version of lm_sensors.

Please help and advise...

Change History

Changed 7 years ago by khali

  • status changed from new to assigned
  • description modified (diff)
  • reporter changed from ticket to michel@…
  • cc michel@… removed
  • version set to 2.10.2
  • owner changed from somebody to khali

Changed 7 years ago by khali

You have an ITE IT8716F, which wasn't supported before kernel 2.6.19. So I am not surprised that you can't get it to work with a 2.6.17 kernel. What is more surprising is that you say it was recognized before with your 2.6.12 kernel. I pretty much doubt that. More likely, it wasn't recognized and you had to force the it87 driver to use your chip, using a "force" module parameter.

Changed 7 years ago by ticket

I can swear that I didn't use any "force" parameter with the previous version, it just basically worked... But if there is any way to force the IT87 driver to recognize my chip, I would be very interested in learning exactly how I could do this ;-)

If you still doubt it worked, I can give you an URL to my cacti graphs before the upgrade, but I'm not sure it would help much in solving the current problem ;-)

Changed 7 years ago by khali

I checked the it87 driver in 2.6.12 again. Back then, it was arbitrarily probing for a device at address 0x290, without reading from the LPC configuration space which device that was. So you are right, the old driver would have "worked" with a more recent ITE chip such as the IT8716F without using a force parameter. Possibly with negative side effects though, as this chip wasn't actually supported. This arbitrary probing was removed in 2.6.15 as it was unreliable and potentially dangerous. This explains why the it87 driver no longer "works" for you in 2.6.17.

It used to be possible to force the it87 driver to attach to an unsupported device, but this possibility was lost at the same time, so you won't be able to use that either.

So your only chance now is to upgrade to kernel 2.6.19, or to patch your 2.6.17 kernel to add proper IT8716F support:  http://jdelvare.pck.nerim.net/sensors/hwmon-it8716f-it8718f-v4-2.6.17.patch

Changed 7 years ago by khali

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.