Ticket #2343 (closed enhancement: fixed)

Opened 6 years ago

Last modified 5 years ago

Support for IT8720?

Reported by: ticket Owned by: fmyhr
Priority: minor Milestone:
Component: hardware Version: kernel
Keywords: Cc: clive@…, sebastian.lipponer@…, Jean-Marc@…

Description

Are there any plans to support ITE IT8720 Super IO chip? I recently bought a Gigabyte EP45 board that uses this IO chip.

Attachments

hwmon-it87-add-it8720f-support.patch Download (8.3 KB) - added by khali 6 years ago.
Add support for the ITE IT8720F

Change History

Changed 6 years ago by ticket

I also bought such a Gigabyte board recently. I am very interested in support for this IO chip. I am also willing to help in testing.

CC: sebastian.lipponer@…

Changed 6 years ago by khali

  • cc sebastian.lipponer@… added

I have added an entry for the IT8720 on the Devices page, and detection for that chip to sensors-detect. Without a datasheet there's not much more we can do.

Changed 6 years ago by khali

We have a datasheet now.

Changed 6 years ago by fmyhr

  • owner changed from somebody to fmyhr
  • status changed from new to assigned

I'm working on adding support for the IT8720 to the it87 driver. Hope to post some code for testing "soon".

Changed 6 years ago by ticket

Hi "fmyhr",

Did you get a chance to work on this? I just buy a brand new ASUS M3A78 motherboard, and I have the same issue. Is there a way for me to help you?

Thanks,

JM

cc:Jean-Marc@Spaggiari.org

Changed 6 years ago by khali

  • cc Jean-Marc@… added
  • version set to kernel

A patch contributed by Jean-Marc Spaggiari is now available for testing. I'll attach it to this ticket. This patch will go into Linux kernel version 2.6.29.

Changed 6 years ago by khali

Add support for the ITE IT8720F

Changed 6 years ago by ticket

Cool. Thank you! Need to go figure out sensors.conf.

it8720-isa-0290
Adapter: ISA adapter
in0:         +1.17 V  (min =  +0.00 V, max =  +4.08 V)   
in1:         +1.94 V  (min =  +0.00 V, max =  +4.08 V)   
in2:         +0.11 V  (min =  +0.00 V, max =  +4.08 V)   
in3:         +2.99 V  (min =  +0.00 V, max =  +4.08 V)   
in4:         +0.82 V  (min =  +0.00 V, max =  +4.08 V)   
in5:         +0.06 V  (min =  +0.00 V, max =  +4.08 V)   
in6:         +0.13 V  (min =  +0.00 V, max =  +4.08 V)   
in7:         +2.16 V  (min =  +0.00 V, max =  +4.08 V)   
in8:         +3.28 V
fan1:       4383 RPM  (min =    0 RPM)
fan2:          0 RPM  (min =    0 RPM)
fan3:       1024 RPM  (min =    0 RPM)
fan4:       1336 RPM  (min =    0 RPM)
temp1:       +41.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = transistor
temp2:       +28.0°C  (low  = +128.0°C, high = +61.0°C)  sensor = thermal diode
temp3:       +42.0°C  (low  = +128.0°C, high = +56.0°C)  sensor = transistor
cpu0_vid:   +0.000 V

Changed 5 years ago by khali

The patch has gone upstream now. Frank, I think we can close this ticket now?

Changed 5 years ago by fmyhr

  • status changed from assigned to closed
  • resolution set to fixed

Yes. Thank you, Jean-Marc and Jean.

Note: See TracTickets for help on using tickets.